TL;DR instructions below!


Some users have reported hiss and/or a clicking artifact (but not limited to) when receiving MIDI note messages.

If you are experiencing noise issues when using MIDI even if your unit is not powered on, this is probably the fix for you!


We have discovered that lifting the MIDI IN jack pins of the main processing PCB eliminates the noise.  We are printing plugs to be installed in the ZEBUs as a simple fix which will not affect the functionality of the ZEBU whatsoever.

The only downside is that the board will have to be partially removed with a 1/16 hex key to increase the clearance and allow us to insert the jack pug.  I would be happy to do this for you but if you're willing, it's very easy.  
Even if you mess up, it won't affect your warranty!

Please fill out the form below and we will send out the plug asap. Please see instructions below.

Please fill out our warranty repair form (https://empresseffects.wufoo.com/forms/empress-effects-request-for-repair/), and mention that you need to be sent the part and I will convert form repair to a parts shipment.

If you would rather have us install it, just mention that in the comments (trust me you can do it, it's very easy!)


Instructions:

The ZEBU foam packaging works really nicely as a workbench jig!

Step 1

remove all but one of the hex screws with a 1/16 hex key.

Step 2

Slightly loosen the final hex screw to raise the board up a bit and insert the MIDI plug into the right jack, which is also the correct jack. 

Step 3

replace and tighten all hex screws as shown (snug, don't overtighten) - see trick below

Here's a little trick: 

With the screw laying on your workbench, insert the hex key with your finger holding the side of the screw and hex key shaft to easily maneuver them into place.


All done!